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Guia de laboratorio

Presentamos en este documento informacidn util para poder seguir
correctamente las practicas del curso.

1. Acceso a los ordenadores del laboratorio

Para acceder a los ordenadores del laboratorio se debe introducir como usuario
y contrasena tu NIF. En el caso de que este acceso no funcionara es posible
usar temporalmente el usuario a1u y con la contrasefa a1u.

El directorio home del usuario se borra cuando cierras la sesion, por lo que
debes tener cuidado de copiar tus ficheros en el disco USB o en el repositorio
CVS del curso J2EE.

2. CD-ROMs y discos USB en Linux

Para poder leer un CD-ROM o poder leer/grabar en el lapiz USB, es necesario
montar el dispositivo en Linux.

e Para montar un CD, lo introducimos en el lector y tecleamos:

mount /mnt/cdrom

Con eso, yendo al directorio /mnt/cdrom accederemos al directorio raiz
del CD. Una vez hayamos terminado es necesario desmontarlo antes de
extraerlo, para lo cual teclearemos:

umount /mnt/cdrom

o Para usar el lapiz USB, también hay que montarlo en Linux.
Teclearemos:

mount /mnt/usb

Y de forma similar al CD-ROM, para desmontarlo y extraerlo después,
tecleamos:

umount /mnt/usb

3. Directorio de trabajo de Eclipse

Eclipse es el entorno de programacién que se va a usar en todas las
asignaturas del curso. Eclipse guarda todos los proyectos en un directorio de
trabajo que es posible seleccionar. Recomendamos que uses como directorio
de trabajo un directorio del disco USB. Puedes llamarlo eclipse. Primero debes
crearlo en el disco USB:



mount /mnt/usb
cd /mnt/usb
mkdir eclipse

Y después debes seleccionarlo al arrancar Eclipse, como muestra la siguiente
figura:

FB Do Warkspace Launcher

Select a workspace

Eclipse Platform stores your projects in a directory called a workspace.
Select the workspace directory to use for this session.

Workspace: /mnt/usb/eclipsel ;_- m { Browse..

[ Use this as the default and do not ask again

f Cancel 3 f‘ oK '3

De esta forma podras usar el mismo directorio de trabajo y trabajar con los
mismos proyectos en cualquier ordenador.

4. Uso del repositorio CVS del curso J2EE

Se ha insalado en el servidor del curso de especialista un repositorio CVS para
guardar los ejercicios y trabajos que se van a desarrollar a lo largo del curso.
Cada alumno es propietario de un conjunto de moddulos (directorios) del
repositorio y alli se deberan guardar los ejercicios para que sean corregidos por
los profesores del curso.

Identificador de usuario

Cada alumno tiene un identificador de usuario y una contrasefa unica en el
repositorio CVS. De esta forma solo tu (y el profesor, para poder corregir los
ejercicios) tienes acceso a tus modulos CVS.

Para cambiar tu contrasefia debes conectarte con ssh al servidor
www.j2ee.ua.es Y ejecutar el comando passwd. Supongamos que tu usuario es

asimov.

localhost$ ssh asimov@www.j2ee.ua.es
asimovl@www.j2ee.ua.es's password: <contrasefia antigua>
www.j2ee.ua.es$ passwd

Changing password for user asimov.

Changing password for asimov

(current) UNIX password: <contrasefia antigua>

New password: <nueva contraseria>

Retype new password: <nueva contrasena>

passwd: all authentication tokens updated successfully.




La nueva contrasefa debe ser una buena contrasefa UNIX: ser
suficientemente larga y contener caracteres y numeros. Si olvidaras la
contrasefna puedes enviar un correo al administrador del repositorio
(malozano@dccia.ua.es).

Repositorio CVS

El repositorio CVS del curso es accesible desde cualquier ordenador conectado
a Internet. Cada alumno tiene disponible un conjunto de modulos (directorios)
en los que puede mantener de forma remota los proyectos en los que esta
trabajando. En concreto, estan disponibles 15 modulos (uno por cada
asignatura del curso) mas un modulo miscelanea a tu disposicion.

La tecnologia CVS permite realizar un control de versiones, de forma que cada
vez que se sube un proyecto al repositorio solo se guardan los cambios
realizados con respecto a la version ya existente. Es posible recuperar
versiones anteriores del proyecto o incluso mantener varias ramas con
versiones paralelas de un mismo proyecto. Si estas interesado en conocer mas
caracteristicas de CVS puedes consultar los siguientes recursos:

Los datos del repositorio CVS son los siguientes:

Direccidén: www.j2ee.ua.es
Camino del repositorio: /usr/local/cvs
Modo de acceso: extssh

Existen multiples clientes para operar con CVS. Uno de los mas interesantes
esta integrado en Eclipse. A continuacion vamos a ver de forma detallada como
operar con él.

Coémo subir por primera vez un proyecto a un repositorio

Cada alumno tiene disponible los siguientes modulos (donde <aiu> es el
identificador del usuario del alumno).

<alu>/ejb
<alu>/integr
<alu>/java-hd
<alu>/jdbc
<alu>/jsp
<alu>/mensajes
<alu>/misc
<alu>/patrones
<alu>/proyecto-1
<alu>/proyecto-2
<alu>/rmi
<alu>/seguridad
<alu>/serv-aplic
<alu>/servlets
<alu>/serv-web
<alu>/xml



Supongamos que queremos subir un proyecto (sesion07) al modulo java-hd
del alumno asimov. En Eclipse los proyectos se corresponden con directorios.
En la vista Navigator tenemos la lista con todos los proyectos del espacio de
trabajo. Supongamos que el proyecto sesion01 contiene los ficheros .project
(fichero que esta en todos los proyectos Eclipse y que contiene informacion
sobre el proyecto) y prueba. txt:

06 Resource - prueba.txt - /Users/domingo/ecipse-para-borrar - Eclipse Platform
- [ Qe | # = o o [ RgResource 2
M [ pruebatxt & B
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[ .project
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Pinchamos sobre el proyecto sesion07 y pulsamos el boton derecho.
Escogemos la opcion Team > Share Project...

[ sits Q| #7 %

P Zsesion New >
Go Into
Open in New Window

aste

Move...
Rename

£y Import...
L Export...

& Refresh
Close Project
9% Outline 32|
An outline is Run
Debug
Team
‘ Compare With

Restore from Local History...

g Apply Patch...
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Share Project...

| Properties I Description
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Aparecera una ventana en la que debemos seleccionar Ccvs como tipo de
repositorio:

8enn Share Project

Share Project

Select the repository plug-in that will be used to share the |
selected project. i=:>

Select a repository type:

wievs
wit SUN

< Back E Finish ( Cancel )

A

Luego hay que proporcionar los datos del repositorio CVS. Estos datos se
grabaran en el directorio de trabajo de Eclipse y no tendras que introducirlos de
nuevo. Es recomendable no grabar tu contrasefa de usuario si estas en un
ordenador publico.

8nn Share Project

Enter Repository Location Information

Define the location and protocol required to connect with an CVS
existing CV5 repository.

Location
Host: waw. jZee.uaes W F_-j
Repository path: | fusr/local/cvs . |~_-i

Authentication

User: asimow

Password: |sswes N

Cannection

;
Connection type: | extssh |%]

a Use Default Port

C Use Port:

[ save Password

15, Saved passwords are stored on your computer in a file that's difficult,
but not impossible, for an intruder to read.

 <Back G—Hn:r:w—'* Finish ( Cancel )

i




Después debemos indicar el médulo (directorio) en el que queremos guardar el
proyecto. Sera un nuevo modulo dentro del ya existente asimov/java-hd y lo
llamaremos con el mismo nombre del proyecto: asimov/java-hd/sesion01. LO
hacemos asi por conveniencia, ya que podriamos darle al médulo CVS un
nombre distinto al del proyecto. Eclipse sube al nuevo directorio CVS el
contenido del proyecto actual (sus ficheros) y no el propio directorio.

® 0 Share Project

Enter Module Name

Select the name of the module in the CVS repository. v

P =
. Use project name as module name

Efl Use specified module name: asimov/java-hd/sesion01 _!_

C Use an exisiting module (this will allow you to browse the modules in the
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= proyecto-1
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= rmi

= seguridad

= serv-aplic
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Pulsando el boton Next> aparecera la siguiente pantalla en la que podras
revisar qué ficheros se van a guardar en el médulo recién creado. Aparecen
con un signo + los ficheros que se van a afadir al médulo. Pulsando en el
icono de commit (marcado en rojo) se actualizan los ficheros en el repositorio.
El comando commit es un comando CVS con el que se guardan los cambios en
el repositorio.



enon Share Project
Share Project Resources
Review and commit the project resources CVs
-
Changes kE . ‘@E— (%
v B sesion01 .[.M.jZeE.ua.Esl.
& project  (ASCI ~kkv)
[Ee» pruebatxt (ASCI ~kkv)
< Back Next > HH—’ ( caneel )

Una vez guardados los ficheros en el repositorio, el proyecto quedara enlazado
al repositorio CVS. En la vista Navigator aparece el servidor CVS asociado al

proyecto:

ens Resource - prueba.txt - /U
jc3- [ Qe [ # [ %0 v o

m = H] " prueba

|E|<}==é>' Esto o

> I=fsesion0l  [www.jZee.ua.es) -

O— "
o= Outline 2 =08
An outline is not available.

Por ultimo podemos explorar el repositorio CVS para comprobar que estan
guardados nuestros ficheros. Lo hacemos seleccionando la opcion del menu:
Window > Open Perspective > CVS Repository Exploring. Aparecera una
nueva perspectiva (conjunto de vistas) de Eclipse en la que podemos explorar
el repositorio CVS que acabamos de actualizar:



06 CVS Repository Exploring - prueba.txt - fUsers/domingo/ecipse-para-borrar - Eclipse Platform
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Para cambiar de nuevo a la perspectiva anterior (llamada Resource)
pinchamos el icono marcado en rojo o seleccionamos la opcion de menu:
Window > Open Perspective > Resource.

Ciclo de trabajo

Cuando estamos trabajando con un proyecto que reside en un repositorio CVS
debemos ser cuidadosos en seguir siempre el mismo ciclo de trabajo, sobre
todo si el repositorio esta compartido entre varios usuarios o si accedemos a él
desde distintos ordenadores.

Una vez subido por primera vez un proyecto a un repositorio, el ciclo de trabajo
con el proyecto siempre sera el mismo:

1. Actualizar el proyecto local con los cambios del repositorio (update)
2. Trabajar en el proyecto local
3. Subir los cambios al repositorio (commit)

Otra operacidn que puede ser necesaria en algun momento es obtener un
proyecto completo de un repositorio.

Vamos a detallar cada una de estas operaciones, empezando por esta ultima.
Coémo obtener un proyecto del repositorio
Vamos a obtener el mismo proyecto que acabamos de subir y guardarlo en otro

proyecto de Eclipse. Esto nos va a servir para simular que se esta accediendo
a un mismo repositorio desde distintos clientes.



Primero se debe escoger la opcién de menu File > New > Project... y
seleccionamos como wizard Checkout Projects from CVS.

enn New Project

Select a wizard

S

Create a new project by checking out an existing praject from a CVS repository.

Wizards

;i’lJEVEPI'DJEEt
i Plug-in Project
¥ E=cvs
¥ Checkout Projects from Cvs
> Zjava
(= Plug-in Development
¥ (=simple
ﬁPrmect

v

< Back Hmh-g ( cancel

£

Después seleccionamos el repostorio y el médulo que queremos obtener. En
nuestro caso, es el moédulo asimov/java-hd/sesion01:

@00 Checkout from CVS

Select Module

| Select the module to be checked out from CVS Cvs

C Use specified module name:  asimov/java-hd/sesion01

8 Use an exisiting madule (this will allow you to browse the modules in the repository)

¥ [Zasimov

P =

P [ =integr

¥ [=java-hd
¥ [=sesion0l
= jdbc
[=jsp
(= mensajes
= misc
(= patrones
= proyecto-1
[= proyecto-2
Ermi X
= seguridad s
(= serv-aplic
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Pulsamos Next> y aparece la siguiente ventana en la que podemos darle
nombre al proyecto en el que vamos a descargar el modulo. Lo llamamos
sesion01-bis:



fenn Check Out As
Check Out As.

Select the method of check out

Choose how to check out folder 'sesion01’

Check out as a project configured using the New Project Wizarc
(Only available when the .project file does nat exist in the repository)
@ Check out as a project in the workspace

Project Name: sesion01-bis

: Check out into an existing project

( <Back (

Next > ) Cancel ) (‘ Finish ’
A

Ahora tendremos dos proyectos conectados al mismo mddulo del repositorio.
Recuerda que esta configuracion no es habitual; sélo estamos haciendo una
demostracidon para comprobar algunas de las caracteristicas de CVS.

8eo0e Resource - prueba.txt - /
| ci- Q- | # ¥ v s

E- m!!m' g b = B[ [E prueb

= 4:{‘? - Esto

¥ lFsesion0l [www.jZee.ua.es|
[} .project 1.1 (ASCI -kkev)
E pruebatxt 1.1 (ASCI -k
¥ IFsesion0l-bis [wwwj2ee.ua.es]
[} .project 1.1 (ASCI -kkv)
) prueba.txt 1.1 (ASCIH kkyv)

Coémo subir al repositorio cambios en el proyecto local

Una vez creado o descargado un repositorio en un proyecto haremos
modificaciones en el proyecto local: modificaremos el contenido de algun
fichero, crearemos nuevos ficheros y directorios o borraremos ficheros
existentes. Eclipse marca todos aquellos recursos que se han modificado con
un simbolo especial (">").

Por ejemplo, selecciona el fichero prueba.txt del proyecto sesion07-bis,
modifica su texto y salvalo. Adade también un directorio nuevo con un fichero
llamado prueba2.txt. La vista Navigator de Eclipse debe mostrar lo siguiente:



‘806 Resource - prueba2.txt - fUsers/domingo/ecipse-para-b|
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An outline is not available.

Nota que se han marcado los ficheros que se van a modificar en el repositorio.
Para grabar (commit) los cambios en el repositorio, pincha el proyecto
sesion01-bis y selecciona con el boton derecho del ratén la opcion Team >
Commit.... Aparecera una ventana preguntando si quieres anadir el nuevo
recurso (notas/prueba2.txt). Debes decir que si. Aparecera la ventana didlogo
Commit en la que podras escribir un comentario sobre los cambios que has
realizado:

ense Commit

Edit the commit comment;

Modificado el fichero pruebal.txt.
Afiadida el directorio notas.
Anadido el fichero notas /prueba2.txt.

a y

Choose a previously entered comment;

Cancel ) é—'ﬂ*—i

Una vez que aceptas el commit Eclipse se conecta con el repositorio y
actualiza los cambios. Veras que desaparece el signo ">" que marcaba las
diferencias con el repositorio.

Puedes comprobar en la perspectiva CVS Repository Exploring que ya se
encuentran los nuevos ficheros en el repositorio. Pinchando en cualquiera de
los ficheros y pulsando el boton derecho podras ver los comandos que puedes
usar sobre un recurso del repositorio. El mas comun es Show in Resource
History, que muestra las anotaciones de los sucesivos cambios que has ido
guardando:



) €5 Resource History 82
CVS Resource History (prueba.txt)

Revision
*1.2
1.1

Tags

=g
-+,
F |~
Date Author Comment
13/10/04 & asimov Modificado el fichero prueba:
12710/04 7. asimowv *** ampty log message ***

Modificado el fichero pruebal.txt.
Afadido el directorio notas.
Afadido el fichero notas/prueba2.txt.

Puedes comprobar también en la vista CVS Repositories que el directorio notas
no lleva una etiqueta con su numero de version. Esto se debe a que CVS no
trata los directorios como recursos.

Cémo actualizar el proyecto local con cambios del

repositorio

Por ultimo, si se ha modificado el repositorio y queremos actualizar el proyecto
local debemos hacer lo siguiente. Seleccionamos el proyecto local (en este
caso, sesion01) Yy pulsando el botén derecho escogemos la opcion Team >

Update....

eonsn
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Apply Patch...

Properties
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Change ASCII/Binary Property...
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Share Project..
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Disconnect...

En la perspectiva de Team Synchronizing podemos comprobar qué ficheros se

van a actualizar:
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Pulsamos en el icono de aceptar los cambios y el proyecto quedara actualizado.

Por ultimo, para dejar el mddulo limpio y poder usarlo de nuevo en la
asignatura Java y Herramientas de Desarrollo, borramos todos los ficheros y
directorios del proyecto sesion071 y hacemos commit. Con eso se borraran
todos los ficheros del moédulo asimov/java-hd/sesion01. Sin embargo, no se
borrara el médulo; en CVS no se pueden eliminar modulos (directorios) de
forma remota. Se podria hacer “manualmente” entrando con ssh en el servidor
y borrando el directorio:

localhost$ ssh asimov@www.j2ee.ua.es
www.j2ee.ua.es$ rmdir -rf /usr/local/cvs/asimov/java-hd/sesion01



